
# [ Data Analysis in Excel ] {CheatSheet}

1. Basic Excel Operations

● AutoFill: Drag the fill handle (small square in the bottom right of
a cell) to fill cells.

● Filtering Data: Select the range → Data → Filter.
● Sorting Data: Select the range → Data → Sort.

2. Excel Functions for Basic Arithmetic

● SUM: =SUM(A1:A10) - Adds all numbers in a range.
● AVERAGE: =AVERAGE(B1:B10) - Calculates the average of numbers in a

range.
● MIN: =MIN(C1:C10) - Finds the smallest number in a range.
● MAX: =MAX(D1:D10) - Finds the largest number in a range.
● SUBTOTAL: =SUBTOTAL(1, E1:E10) - Calculates the sum of a range,

ignoring filters.

3. Date and Time Functions

● TODAY: =TODAY() - Returns the current date.
● NOW: =NOW() - Returns the current date and time.
● YEAR: =YEAR(F1) - Extracts the year from a date.
● MONTH: =MONTH(G1) - Extracts the month from a date.
● DAY: =DAY(H1) - Extracts the day of the month from a date.

4. Text Functions

● CONCATENATE/CONCAT: =CONCATENATE(A1, B1) or =CONCAT(A1, B1) - Joins
two or more text strings.

● LEFT: =LEFT(I1, 3) - Extracts a given number of characters from
the start of a string.

● RIGHT: =RIGHT(J1, 3) - Extracts a given number of characters from
the end of a string.

● MID: =MID(K1, 2, 4) - Extracts a substring from the middle of a
string.
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● UPPER/LOWER/PROPER: =UPPER(L1), =LOWER(L1), =PROPER(L1) - Changes
text to upper, lower, or proper case.

5. Logical Functions

● IF: =IF(M1>10, "Yes", "No") - Performs a logical test and returns
one value for TRUE and another for FALSE.

● AND/OR: =AND(N1>5, O1<10), =OR(P1=1, Q1=2) - Returns TRUE if all
or any of the arguments respectively are TRUE.

● NOT: =NOT(R1) - Reverses the logic of its argument.
● IFERROR: =IFERROR(S1, "Error") - Returns a custom result if an

error occurs in the formula.

6. Lookup and Reference Functions

● VLOOKUP: =VLOOKUP(T1, A1:B10, 2, FALSE) - Looks for a value in the
first column of a table and returns a value in the same row.

● HLOOKUP: =HLOOKUP(U1, A1:C3, 2, FALSE) - Looks for a value in the
first row of a table.

● INDEX: =INDEX(A1:C10, 3, 2) - Returns the value of a cell in a
specified row and column number.

● MATCH: =MATCH("item", A1:A10, 0) - Returns the relative position
of an item in a range.

● XLOOKUP (for newer Excel versions): =XLOOKUP(V1, A1:A10, B1:B10) -
Searches a range for a match and returns the corresponding item
from a second range.

7. Financial Functions

● PMT: =PMT(rate, nper, pv) - Calculates the payment for a loan
based on constant payments and a constant interest rate.

● FV: =FV(rate, nper, pmt) - Calculates the future value of an
investment.

● NPV: =NPV(rate, value1, [value2], ...) - Calculates the net
present value of an investment.

● IRR: =IRR(values) - Calculates the internal rate of return for a
series of cash flows.
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● XNPV (for non-periodic cash flows): =XNPV(rate, values, dates)

8. Statistical Functions

● COUNT/COUNTA: =COUNT(W1:W10), =COUNTA(X1:X10) - Counts the number
of cells with numbers and non-blank cells.

● MEDIAN: =MEDIAN(Y1:Y10) - Finds the median of a group of numbers.
● MODE: =MODE(Z1:Z10) - Returns the most frequently occurring number

in a data set.
● STDEV.P/STDEV.S: =STDEV.P(AA1:AA10) - Calculates the standard

deviation for an entire population or a sample.
● VAR.P/VAR.S: =VAR.P(AB1:AB10) - Calculates the variance for an

entire population or a sample.

9. Data Analysis Tools

● PivotTables: Insert → PivotTable - Summarizes large amounts of
data quickly and flexibly.

● Data Tables: Data → What-If Analysis → Data Table - Performs
multiple calculations on your data.

● Solver: Data → Solver - Finds an optimal value for a formula in
one cell.

● Goal Seek: Data → What-If Analysis → Goal Seek - Adjusts a value
to achieve a desired goal.

● Scenario Manager: Data → What-If Analysis → Scenario Manager -
Creates and saves different groups of values on a worksheet.

10. Charts and Graphs

● Creating a Chart: Insert → Recommended Charts → Select Chart Type.
● Creating a PivotChart: Insert → PivotChart.
● Formatting Charts: Use Chart Tools for layout and design

adjustments.
● Creating Sparklines: Insert → Sparklines → Select Type.
● Conditional Formatting in Charts: Use the Format Data Series

options.
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11. Conditional Formatting

● Applying Conditional Formatting: Home → Conditional Formatting.
● Data Bars/Color Scales/Icon Sets: Home → Conditional Formatting →

Choose a style.
● Creating Custom Rules: Home → Conditional Formatting → New Rule.
● Highlighting Cell Rules: Home → Conditional Formatting → Highlight

Cells Rules.
● Managing Rules: Home → Conditional Formatting → Manage Rules.

12. Data Validation

● Creating Drop-Down Lists: Data → Data Validation → Allow: List.
● Setting Number, Date, or Time Ranges: Data → Data Validation →

Allow: Date, Time, or Decimal.
● Custom Validation Based on a Formula: Data → Data Validation →

Allow: Custom.
● Creating Input Messages and Error Alerts: Data → Data Validation →

Input Message/Error Alert.

13. Advanced Excel Features

● Using Power Query (Get & Transform): Data → Get Data → Combine
Queries.

● Utilizing Power Pivot: Manage with the Power Pivot add-in.
● Using Macro Recorder: View → Macros → Record Macro.
● Writing VBA Code: View → Macros → View Macros → Edit.
● Using Form Controls: Developer → Insert → Form Controls.

14. Excel Tables

● Creating a Table: Insert → Table or Ctrl + T.
● Table Slicers for Easy Filtering: Insert → Slicer.
● Referencing Table Elements in Formulas: Use structured references

like Table1[Column1].
● Total Row for Quick Calculations: Table Tools → Design → Total

Row.

By: Waleed Mousa



● Resizing and Formatting Tables: Table Tools → Design → Resize
Table.

15. Advanced Formulas

● Array Formulas: Entered with Ctrl + Shift + Enter.
● Dynamic Arrays (for newer Excel versions): =SORT(), =FILTER(),

=UNIQUE().
● Using INDIRECT for Dynamic References: =INDIRECT("A" & 1).
● Combining IF with AND, OR: =IF(AND(condition1, condition2),

value_if_true, value_if_false).
● Nested IF Statements: =IF(condition1, value_if_true1,

IF(condition2, value_if_true2, value_if_false2)).

16. Text and Data Extraction

● LEFT, RIGHT, MID for Text Extraction: =LEFT(text, num_chars).
● SEARCH, FIND for Position of Substring: =SEARCH("substr", text).
● TEXTJOIN, CONCAT for Joining Text: =TEXTJOIN(delimiter,

ignore_empty, text1, [text2], ...).
● TRIM for Removing Extra Spaces: =TRIM(text).
● VALUE for Converting Text to Number: =VALUE(text).
● SPLIT Text into Columns: Data → Text to Columns.
● SUBSTITUTE to Replace Text: =SUBSTITUTE(text, old_text, new_text).
● LEN to Get Length of Text: =LEN(text).

17. Data Import and Connection

● Import Data from External Sources: Data → Get Data.
● Connecting to SQL Databases: Data → Get Data → From Database.
● Importing Data from Web: Data → Get Data → From Web.
● Refreshing Imported Data: Data → Refresh All.

18. Working with Large Data

● Freeze Panes for Easy Navigation: View → Freeze Panes.
● Splitting Window: View → Split.
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● Using Named Ranges for Easy Reference: Formulas → Name Manager →
New Name.

● Data Consolidation: Data → Consolidate.
● Grouping and Ungrouping Data: Data → Group.

19. Formulas and Features for Business Analysis

● NPV and IRR for Financial Analysis: =NPV(rate, value1, [value2],

...), =IRR(values).
● PMT for Loan Payments: =PMT(rate, nper, pv).
● XNPV and XIRR for Non-Periodic Cash Flows: =XNPV(rate, values,

dates), =XIRR(values, dates).
● Using Data Tables for Scenario Analysis: Data → What-If Analysis →

Data Table.
● Break-Even Analysis Formulas: Custom formulas based on fixed and

variable costs.

20. Excel Add-ins for Enhanced Capabilities

● Using Solver Add-in for Optimization Problems: Data → Solver.
● Analysis ToolPak for Statistical Analysis: Add-ins → Analysis

ToolPak.
● Power Map for Geospatial Analysis: Insert → 3D Map.
● Using Power Query for Advanced Data Transformation: Data → Get &

Transform Data.
● Inquire Add-in for Workbook Analysis and Comparison: Add-ins →

Inquire → Workbook Analysis.

21. Advanced Data Manipulation

● Flash Fill for Pattern Recognition: Data → Flash Fill.
● Using Advanced Filter for Complex Criteria: Data → Advanced.
● Remove Duplicates to Clean Data: Data → Remove Duplicates.
● Text to Columns for Delimited Data: Data → Text to Columns.
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22. Custom Formatting

● Custom Number Formats: Home → Number → More Number Formats.
● Conditional Custom Number Formats: Using custom formats with

conditions in the Format Cells dialog.
● Creating Custom Date Formats: Customizing date display in Format

Cells dialog.
● Using Color in Custom Formats: Incorporating font color changes in

custom formats.

23. Advanced Formulas and Functions

● Nested Functions for Complex Calculations: Combining multiple
functions like IF, VLOOKUP, and MATCH.

● Using INDIRECT for Dynamic Cell Reference: =INDIRECT(ref_text).
● OFFSET for Dynamic Range Selection: =OFFSET(reference, rows, cols,

[height], [width]).
● SUMPRODUCT for Multi-Condition Summing:

=SUMPRODUCT((range1=criteria1)*(range2=criteria2)*sum_range).

24. Data Validation and Error Checking

● Using Data Validation for Controlled Inputs: Data → Data
Validation.

● Circle Invalid Data: Data Validation → Circle Invalid Data.
● Error Checking and Tracing: Formulas → Error Checking.
● Tracing Precedents and Dependents: Formulas → Trace

Precedents/Trace Dependents.

25. Using Forms and Controls

● Creating Forms for Data Entry: Developer → Insert → Form Controls.
● Using Spin Button for Incremental Change: Inserting a spin button

and linking it to a cell.
● Check Boxes for Binary Choices: Using check boxes for Yes/No

selections.
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● Option Buttons for Multiple Choice: Grouping option buttons for
single-choice selection.

26. PivotTable Advanced Techniques

● Calculated Fields in PivotTables: Analyze → Fields, Items, & Sets
→ Calculated Field.

● Grouping Data in PivotTables: Right-click on a field item → Group.
● PivotTable Slicers for Interactive Filtering: Analyze → Insert

Slicer.
● PivotTable Timelines for Date Filtering: Analyze → Insert

Timeline.

27. Advanced Charting Techniques

● Combination Charts for Mixed Data Types: Creating charts with
multiple axis types.

● Secondary Axis for Comparison: Format Data Series → Plot Series On
→ Secondary Axis.

● Dynamic Charts with OFFSET and Named Ranges: Using named formulas
to create dynamic charts.

● Creating Waterfall Charts for Financial Analysis: Insert →
Waterfall Chart.

28. Macros and VBA for Automation

● Recording Macros for Repetitive Tasks: View → Macros → Record
Macro.

● Editing Macros in VBA Editor: View → Macros → View Macros → Edit.
● Writing Custom VBA Functions: Implementing user-defined functions

in VBA.
● Automating Data Analysis with VBA: Writing scripts to automate

complex data analysis tasks.

29. Advanced Statistical Analysis

● ANOVA with Analysis ToolPak: Data Analysis → ANOVA.
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● Regression Analysis: Data Analysis → Regression.
● Correlation Analysis: Data Analysis → Correlation.
● Descriptive Statistics: Data Analysis → Descriptive Statistics.

30. Power Tools for Data Analysis

● Introduction to Power Query for Data Transformation: Data → Get &
Transform Data.

● Using Power Pivot for Data Modeling: Managing Data Model in Power
Pivot.

● DAX (Data Analysis Expressions) in Power Pivot: Writing DAX
formulas for advanced calculations.

● Creating Interactive Dashboards with Power BI: Using Power BI
integration for dynamic reporting.

31. Excel Connectivity

● Connecting to External Databases: Data → Get Data → From Database.
● Using ODBC for Data Import: Data → Get Data → From Other Sources →

From ODBC.
● Linking Excel with Other Office Applications: Embedding and linking

objects with Word, PowerPoint.
● Web Queries to Import Data from the Web: Data → Get Data → From

Web.

32. Excel Options and Customization

● Customizing the Ribbon: Right-click the Ribbon → Customize the
Ribbon.

● Changing Excel Options and Defaults: File → Options.
● Setting Excel Add-ins: File → Options → Add-ins.
● Creating Custom Templates for Reuse: Saving a workbook as an Excel

Template (.xltx).

33. Excel Tips for Large Data Sets
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● Optimizing Performance for Large Workbooks: Best practices like
avoiding volatile functions, minimizing used range.

● Breaking Down Large Workbooks: Splitting data into multiple sheets
or files to improve performance.
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